πŸ”‹ No voltage in OSD? πŸ”‹

πŸ”‹ No voltage in OSD? πŸ”‹

So very recently I had to rebuild by main build as the 5v BEC on my FC gave up the ghost and died πŸ‘»

This isn’t normally a problem cause we all backup are configs from the CLI, right ?

Well I couldn’t find a backup so had to guess my PID’s, Rates, Modes, etc… But that isn’t always a bad thing. Some times it good to wipe the slate clean and start again and discover something new maybe, some new rates?

Learn from my mistake

So before I work out how to restore my OSD voltage reading. Lets go through backing up your betaflight config. So maybe you won’t have to in the future.

Backing up your config is only 3 clicks and 1 command ( yes I counted ). Just follow the GIF be low for step by step directions… simples.

!! Click me for Full screen !!

So what does my problem look like?

OK so the above image is what I’m getting in my OSD…
No Avg Cell Voltage, No Mah Drawn and No Current Draw.
But this could just because I haven’t setup the Power & Battery Tab correctly.

Checking Betaflight.

Well that’s not good….. πŸ™
Betaflight is setup correctly and we have already seen that the correct elements are on the OSD.
But if you look at the top of that image Betaflight isn’t showing any voltage with a lipo plugged in.

Which means my FC is damaged and the Voltage/Current sensor isn’t working 😱

How did this happen Dead on arrival (DOA) or did I kill it soldering on the XT60?
Now that the FC is fully fitted I can’t send it back πŸ™

So what can we learn?

I always test a new FC with a USB and betaflight to make sure its all working and holds a config.
But that doesn’t test the XT60 main input and when you solder the board you invalidate any warranty.
What I should have done is used crocodile clips to test the board more.

TOP TIP: Clip to the FC FIRST then plug in a lipo, I would also use a smoker stopper.

Are we beat? what else can we do?

Nope that at all. We still have timers on the OSD or on our Transmitters.

Found on the OSD Tab within Betaflight

I like to use a Throttle percentage based timer on my X9D+

Higher the throttle faster it ticks down…
0% Throttle = 0 seconds on the timer > 0 seconds real time.
50% Throttle = 1 second on the timer > 1 second real time.
100% Throttle = 2 seconds on the timer > 2 seconds real time.

So the higher your throttle the faster the timer ticks down. So if your cruising around at 40/50% your timer lasts longer cause your not draining your lipo as fast.
The hardest part is working out how long the timer should be set for.

So I’m going to link a timed stingerswam video and let him explain the how to set it up as I copied his method, if done correctly you land at the same voltage every time. Well at least I do.

!! skip to 3:47 for the timer !!

Summary

Just cause something isn’t working as expected doesn’t always mean your done.
Sometimes you can just work around it.
I won’t be in a rush to replace my FC but if this was on my Long Range build.
I would be swapping it straight out.

Test your hardware as much as you can before hitting it with the soldering iron.